Deposit and Withdrawal - Service Degraded

Incident Report for Deriv

Resolved

The issue has been resolved, and all systems are fully operational.
Posted May 30, 2025 - 01:58 GMT

Monitoring

A fix has been implemented and is being monitored to ensure stability and performance. We will share updates once the issue is confirmed to be fully resolved
Posted May 30, 2025 - 01:26 GMT

Identified

We are currently experiencing unexpected technical difficulties with our system. Our team is investigating and will provide further updates as progress is made.
Posted May 30, 2025 - 01:01 GMT