Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 07, 2025 - 05:00 GMT
Scheduled
Spotware, the developer of cTrader, will be performing monthly maintenance during this period to enhance your trading experience.
What to expect: 1. Trading synthetics and cryptocurrencies in cTrader might experience an interruption for about 10 minutes during this period. 2. Internal transfers won't be affected. 3. The Deriv cTrader dashboard will be offline. Trading, deposits, or withdrawals won't be possible on your Deriv cTrader account.
What you should do: 1. Review and manage your open positions before maintenance begins. Modifying or closing positions on cTrader won't be possible during scheduled maintenance.
Our cTrader will be back online as soon as maintenance is complete.
Posted Jun 04, 2025 - 10:41 GMT
This scheduled maintenance affected: cTrader Services.