Services disrupted

Incident Report for Deriv

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:52 GMT

Investigating

We’re currently experiencing technical issues affecting some of our systems.

Our team is investigating and working to restore normal operations as soon as possible.

For urgent queries, please contact support@deriv.com.
Posted Oct 20, 2025 - 09:49 GMT
This incident affected: LiveChat.