Livechat is unavailable at the moment
Incident Report for Deriv
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 16:28 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 04, 2024 - 15:35 GMT
Investigating
We're currently experiencing an issue with our LiveChat and Whatsapp support. These services are unavailable at the moment. Please contact our support team via email at support@deriv.com for further assistance
Posted Jun 04, 2024 - 15:35 GMT
This incident affected: LiveChat.