Livechat and Whatsapp Support are experiencing issues
Incident Report for Deriv
Resolved
This incident has been resolved.
Posted May 05, 2024 - 10:04 GMT
Investigating
We’re currently experiencing an issue with our LiveChat and Whatsapp support. These services are unavailable at the moment. Please contact our support team via email support@deriv.com for further assistance.
Posted May 05, 2024 - 08:54 GMT
This incident affected: LiveChat.