Livechat is currently unavailable.

Incident Report for Deriv

Resolved

This incident has been resolved.
Posted Jul 25, 2022 - 08:10 GMT

Identified

Livechat is currently unavailable. Live chat application team is working on fixing the issue.
Posted Jul 25, 2022 - 07:27 GMT